آموزش نحوه برطرف کردن خطا امنیتی وردپرس

رضا ماندگاری
۱۳۹۶/۰۸/۲۵
نظرات : ۰
بازدیدها : 480

خطا امنیتی وردپرس | این خطا در وردپرس زمانی بوجود می آید که شما قصد دارید در وردپرس افزونه یا قالبی را به روزرسانی کنید.

حتی ممکن است زمانیکه قصد دارید وردپرس را هم آپدیت کنید، این خطا رخ دهد.

دلیل به وجود آمدن خطا امنیتی وردپرس

خطا امنیتی وردپرس ناشی از برقراری ارتباط وردپرس شما با سایت wordprees.org است.

همانطور که می دانید در پیشخوان شما پیامی با این مضمون که ” شما می توانید وردپرس خود را به روزرسانی کنید” وجود دارد.

زمانیکه شما این پیام را می بینید و قصد دارید عمل آپدیت را انجام دهید، خطا امنیتی وردپرس آشکار می شود.

این خطا ناشی از عدم برقراری وردپرس شما با سرور wordprees.org است.

خطایی که در این مواقع نمایش داده می شود مانند تصویر زیر است:

خطا امنیتی وردپرس

خطا امنیتی وردپرس

روش های بسیار زیادی برای رفع این خطا امنیتی وردپرس وجود دارد. اولین و بهترین راه حل، تماس با هاست خود هست ولی اگر مایل به برطرف کردن این مشکل توسط خودتان هستید با این مقاله همراه شوید.

رفع خطا امنیتی وردپرس

توجه کنید این آموزش که در ادامه به آن اشاره خواهد شد مستلزم دسترسی شما به سرور است.

البته در بخش بعدی با لوکال هاست هم آموزش داده خواهند شد.

در قسمت ترمینال سرور خود کد زیر را تایپ کنید:

ssh [email protected]

پس از اتصال کد زیر را تایپ کنید :

sudo nano /etc/hosts

پس از انجام این کار یک فایلی باز خواهد شد که باید در انتهای آن کد زیر را وارد کرد:

۶۶.۱۵۵.۴۰.۲۰۲  api.wordpress.org

حالا تمام تغییرات را ذخیره کنید.

رفع خطا امنیتی وردپرس از طریق لوکال هاست

فایل php.ini را پیدا کرده و آن را باز کنید. سپس به دنبال این کد بگردید:

extension=php_curl.dll;

حال شما باید سمیکالون قبل از کد بالا را حذف کنید و تغییرات را ذخیره کنید.

در مرحله بعد شما باید سرور آپاچی خود را ریستارت کنید.

موفق باشید… 

 

 

اشتراك گذاری نوشته

دیدگاهتان را بنویسید